Nexus Agent Signing Currently Unavailable

Incident Report for Magnet Forensics

Resolved

The issue has now been resolved. If you continue to experience issues creating new Windows and MacOS agents in Nexus, please create a support case for further investigation.
Posted Apr 23, 2026 - 17:09 UTC

Identified

Nexus agent signing is currently unavailable. Customer creation of new Windows and MacOS Nexus agents is affected. The issue has been identified and the Magnet team is working to resolve the issue.
Posted Apr 23, 2026 - 16:10 UTC
This incident affected: Magnet Nexus (Nexus - us-east-1, Nexus - eu-central-1, Nexus - eu-west-2, Nexus - ap-south-1, Nexus - ca-central-1).