Nexus Web Portal - Inaccessible

Incident Report for Magnet Forensics

Resolved

Fix is working as expected and all systems are operating normally.
Posted May 05, 2026 - 20:48 UTC

Update

Nexus team has reported the service is now stable, and being monitored.
Posted May 05, 2026 - 18:38 UTC

Monitoring

Nexus US production is experiencing an outage that we are monitoring as recovered. The outage began at ~2PM EDT. - As of ~2:27 EDT the issue is being monitored as resolving.
Posted May 05, 2026 - 18:37 UTC
This incident affected: Magnet Nexus (Nexus - us-east-1).