Newly Created Cases June 18-22 Not Appearing As Expected

Incident Report for Magnet Forensics

Resolved

We have validated and updated the system with a solution. Customers whose cases were created between June 18-22 and did not appear correctly will now see them all correctly. The cases and all related information are now visible to the appropriate system and case roles.

If you notice anything not appearing correctly, please create a new support case: https://support.magnetforensics.com/s/technical-support
Posted Jun 30, 2026 - 20:48 UTC

Update

We are currently validating our solution and expect to have a more detailed update Monday, 6/29. Customers requiring immediate access to missing cases can safely re-upload their data under the same case name
Posted Jun 25, 2026 - 16:16 UTC

Monitoring

For a brief period of time between June 18-22, newly created cases were not always appearing in the Organization for other users who would normally see them automatically.

We are working on restoring expected access and will share updates as available.
Posted Jun 23, 2026 - 20:10 UTC
This incident affected: Magnet Review (Review - us-east-1, Review - eu-west-2, Review - ca-central-1, Review - ap-southeast-2, Review - sa-east-1).