Review Ingestion Experiencing Severe Delays

Incident Report for Magnet Forensics

Resolved

We have confirmed database performance has returned to normal.
Posted Apr 24, 2026 - 21:35 UTC

Monitoring

We have identified the cause of the issue and implemented a fix. Customer ingestions submitted were queued and are continuing to be processed without further action from the customer. We continue to monitor the status and performance of our database.
Posted Apr 24, 2026 - 20:45 UTC

Investigating

Customers ingesting into Review are experiencing severe delays. We are currently investigating.
Posted Apr 24, 2026 - 19:33 UTC
This incident affected: Magnet One Hub (One Hub - us-east-1), Magnet Nexus (Nexus - us-east-1), Magnet Review (Review - us-east-1), and Graykey Platform Services.